д) Метод парабол (Симпсона)

д) Метод парабол (Симпсона)

Нижегородский муниципальный технический институт им. Р.Е. Алексеева

Кафедра «Прикладная Математика»

Отчет по лабораторной работе №4

Тема: Численные способы интегрирования

5 вариант.

Выполнила: студентка

Группы С11-ЛА-1

Кокушева Ю.В.

Проверил педагог:

Осипенко Н.Н.

Нижний Новгород 2012г.

Оглавление:

1) Постановка задачки………………………………………………………….3

2) Microsoft Excel …………………………………………..…………………3

3) Microsoft Excel(формулы)………………………………………………….4

4) MathCAD………………………………………………………….………...5а) Численное интегрирование..……………………………………………5

б) Способ правых прямоугольников………………………………….........5

в д) Метод парабол (Симпсона)) Способ левых прямоугольников.………………………………………..5

г) Способ центральных прямоугольников………………………………...6

д) Способ трапеций…………………………………………………………6

е) Способ парабол(Симпсона)……………………………………………...7

5) Microsoft Visual C++………………………………………………………..7

а) Способ правых прямоугольников………………………………….........7

б) Способ левых прямоугольников.………………………………………..8

в) Способ центральных прямоугольников………………………………...9

г) Способ трапеций………………………………………………………….9

д) Способ парабол(Симпсона)…………………………………………….10

Ручной счет………………………………………………………………………11


Постановка задачки

Отыскать определенный интеграл , с шагом 0.1, точностью 0.001 на интервале .Для этого воспользуемся д) Метод парабол (Симпсона) численными способами:

1. Способ левых прямоугольников

2. Способ правых прямоугольников

3. Способ центральных прямоугольников

4. Способ трапеции

5. Способ парабол (Симпсона)

Проведем расчеты в программках Microsoft Excel, MathCAD, Microsoft Visual C++ и выполним ручной счет.

2. Microsoft Excel

Microsoft Excel(Формулы)

номер x f(x)
=D1 =1/(1-B2)
=B2+$D$3 =1/(1-B3) =(D2-D1)/10
=B3+$D$3 =1/(1-B4)
=B4+$D$3 =1/(1-B5)
=B5+$D$3 =1/(1-B д) Метод парабол (Симпсона)6)
=B6+$D$3 =1/(1-B7)
=B7+$D$3 =1/(1-B8)
=B8+$D$3 =1/(1-B9)
=B9+$D$3 =1/(1-B10)
=B10+$D$3 =1/(1-B11)
=B11+$D$3 =1/(1-B12)
Способ левых прямоугольников
=СУММ(C2:C11)*D3
Способ правых прямоугольников
=СУММ(C3:C12)*D3
Способ трапеций
=D3*((C2+C12)/2+СУММ(C3:C11))
Способ парабл
нечет чет
=C3+C5+C7+C9+C д) Метод парабол (Симпсона)11 интеграл= =D3/3*(C2+C12+4*A21+2*D21) =C4+C6+C8+C10
Способ центральных пямоугольников
x+h/2 f(x+h/2)
=B2+$D$3/2 =1/(1-B24)
=B3+$D$3/2 =1/(1-B25)
=B4+$D$3/2 =1/(1-B26)
=B5+$D$3/2 =1/(1-B27)
=B6+$D$3/2 =1/(1-B28)
=B7+$D$3/2 =1/(1-B29)
=B8+$D$3/2 =1/(1-B30)
=B9+$D$3/2 =1/(1-B31)
=B10+$D$3/2 =1/(1-B32)
=B11+$D$3/2 =1/(1-B33)
интеграл д) Метод парабол (Симпсона)= =D3*СУММ(C24:C33)

MathCAD

Ч и с л е н н о е и н т е г р и р о в а н и е
М е т о д п р а в ы х п р я м о у г о д) Метод парабол (Симпсона) л ь н и к о в

М е т о д л е в ы х п р я м о у г о л ь н и к о в
М е т о д ц е н т р а л ь н ы х п р я д) Метод парабол (Симпсона) м о у г о л ь н и к о в
М е т о д т р а п е ц и й

М е т о д п а р а б о л (м е т о д С и п с о д) Метод парабол (Симпсона) н а )
Н е ч е т н ы е т о ч к и
Ч е т н ы е т о ч к и

5. Microsoft Visual C++

А) Способ правых прямоугольников

#include "stdafx.h"

#include "iostream"

#include

using namespace std;

double f(double x)

{

return 1/(1-x);

}

int main д) Метод парабол (Симпсона)()

{

setlocale(LC_ALL,"Russian");

double S,h,a=2,b=3,x,I;

int n=10,i;

printf("a=%1.1f\tb=%1.1f\tn=%2d\t\n",a,b,n);

S=0;

h=(b-a)/n;

for(i=1;i

{

x=a+i*h;

S+=f(x);

cout<

}

I=h*S;

cout<<"\nОтвет: I="<

char st;

cin>>st д) Метод парабол (Симпсона);

}

А) Способ левых прямоугольников

#include "stdafx.h"

#include "iostream"

#include

using namespace std;

double f(double x)

{

return 1/(1-x);

}

int main()

{

setlocale(LC_ALL,"Russian");

double S,h,a=2,b=3,x,I;

int n=10,i;

printf("a=%1.1f\tb=%1.1f\tn=%2d\t\n",a,b,n);

S=0;

h=(b д) Метод парабол (Симпсона)-a)/n;

for(i=0;i

{

x=a+i*h;

S+=f(x);

}

I=h*S;

cout<<"\nОтвет: I="<

char st;

cin>>st;

}

В) Способ центральных прямоугольников

#include "stdafx.h"

#include "iostream"

#include

using namespace std;

double f(double x)

{

return 1/(1-x);

}

int main()

{

setlocale(LC_ALL,"Russian");

double I д) Метод парабол (Симпсона)0,I1,h,eps=0.001,a=2,b=3,x;

int n=10,j;

printf("a=%2.2f\tb=%2.2f\teps=%3.3f\nn=%2d\t\n",a,b,eps,n);

I0=1E+10;

I1=0;

while(fabs(I1-I0)>eps)

{

I0=I1;

h=(b-a)/n;

I1=0;

for(j=0;j

{

x=a+(j+0.5)*h д) Метод парабол (Симпсона);

I1=I1+f(x)*h;

}

n=2*n;

}

cout<<"\nОтвет I="<

char st;

cin>>st;

}

Г) Способ трапеций

#include "stdafx.h"

#include "iostream"

#include

using namespace std;

double f(double x)

{

return 1/(1-x);

}

int main()

{

setlocale(LC_ALL,"Russian");

double I0,I1,h,eps=0.001,a=2,b=3,x;

int n=10,j д) Метод парабол (Симпсона);

printf("a=%2.2f\tb=%2.2f\teps=%3.3f\nn=%2d\t\n",a,b,eps,n);

I0=1E+10;

I1=0;

while(fabs(I1-I0)>eps)

{

I0=I1;

h=(b-a)/n;

I1=0;

for(j=1;j

{

x=a+j*h;

I1+=f(x)*h;

}

I1=I1+h*(f(a)+f д) Метод парабол (Симпсона)(b))/2;

n=2*n;

}

cout<<"\nОтвет I="<

char st;

cin>>st;

}

д) Способ парабол (Симпсона)

#include "stdafx.h"

#include "iostream"

#include

using namespace std;

double f(double x)

{

return 1/(1-x);

}

int main()

{

setlocale(LC_ALL,"Russian");

double I0,I1,S1,S2,h,eps=0.001,a=2,b=3,x;

int n=10,j д) Метод парабол (Симпсона);

printf("a=%2.2f\tb=%2.2f\teps=%3.3f\nn=%2d\t\n",a,b,eps,n);

I0=1E+10;

I1=0;

while(fabs(I1-I0)>eps)

{

I0=I1;

h=(b-a)/n;

S1=0;

j=1;

for(j;j<=n-1;j++)

{

x=a+j*h;

S1+=f(x);

}

j=1;

S2=0;

for(j++;j

{

x=a+j д) Метод парабол (Симпсона)*h;

S2+=f(x);

}

I1=(h/3)*(f(a)+f(b)+4*S1+2*S2);

n=2*n;

}

I1=I1/2;

cout<<"\nОтвет: I="<

char st;

cin>>st;

}


d-rodovaya-travma-1-opredelenie-2-prichini-3-sposobstvuyushie-faktori-4-vidi-5-rodovaya-travma-cherepa-i-pozvonochnika-vidi-i-posledstviya.html
d-rrrsrrryo-rrrr-rrrsrsrrsryor-rrrr-rrrsrsrrsryor-rrrrrr-rrrrsrrsrrrr-srrsrsrss-rrrsrr.html
d-rrsryosr-rs-rsrrsrsrrryos-sssrrrrrr-rrrrrrsr-ryo-srrrsrrrryos-rr-rsrrs-rrsrrrrrrssryo-rr-ssrsssrryov16-ryo-17-rrrsr.html